Delayed screenshots processing
Incident Report for Workpuls
Resolved
This incident has been resolved.
Posted Jul 30, 2021 - 01:01 UTC
Investigating
Team is currently investigating delayed screenshots processing.
Posted Jul 29, 2021 - 18:08 UTC
This incident affected: Data collection and processing (Screenshots).