Screenshots delayed
Incident Report for Insightful
Resolved
All screenshots are processed.
Posted Apr 29, 2020 - 05:59 UTC
Identified
Some Workpuls customers are reporting delays in screenshot visibility in their admin Dashboard. Workpuls is investigating the situation and will update back.
Posted Apr 28, 2020 - 12:16 UTC
This incident affected: Data collection and processing (Screenshots).