Delayed Activities
Incident Report for Workpuls
Resolved
This incident has been resolved.
Posted May 29, 2020 - 19:53 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 28, 2020 - 14:11 UTC
Identified
We are currently experiencing a delay in loading the activities into your account. They will show up a little bit later than usual. The team is dealing with this, and we'll notify you as soon as it's resolved.
Posted May 28, 2020 - 08:19 UTC
This incident affected: Data collection and processing (Apps and websites usage, Productivity).