Data processing delayed
Incident Report for Workpuls
Resolved
This incident has been resolved.
Posted Mar 29, 2021 - 12:31 UTC
Update
We are continuing to investigate this issue.
Posted Mar 29, 2021 - 07:40 UTC
Investigating
We are currently investigating and we will update this page soon.
Posted Mar 29, 2021 - 07:37 UTC
This incident affected: Data collection and processing (Apps and websites usage, Screenshots, Shifts, Productivity).